Exchange 2010 SP1 Kurulduktan Sonra Exchange Management Shell Kısayolu Kayboldu.

closeBu yazı 6 yıl 27 gün önce yayınlanmış olduğundan güncelliğini yitirmiş veya içeriğindeki bilgilerin geçerliliği kaybolmuş olabilir. Herhangi bir yanlış anlaşılmadan bu site sorumlu değildir.

Exchange 2010 Service Pack 1 kurduktan sonra Exchange Management Shell kısayolu yok oluyor. Bu problemin nedeni SP1 ile birlikte bazı Powershell scriptlerin (.ps1) kaldırılmış olması. Bu konuda henüz kesin bir çözüm sunulmadı ancak aşağıdaki workaround’u uygulayarak sorunu giderebilirsiniz.

1. “ConnectFunctions.ps1” , “RemoteExchange.ps1” ve “CommonConnectFunctions.ps1” powershell scriptlerin “%ExchangeInstallPath%\\bin” klasörünün altından emin olun. Eğer bu scriptler yok ise SP1 kurulum dosyaları içerisinde \\setup\\serverroles\\common altından “%ExchangeInstallPath%\\bin” içerisine kopyalayın.

2. Desktop üzerinde yeni bir kısayol oluşturun.

3. Type the Location of the item kısmına

%SystemRoot%\\System32\\WindowsPowerShell\\v1.0\\powershell.exe -noexit -command “. ‘%ExchangeInstallPath%\\bin\\RemoteExchange.ps1’; Connect-ExchangeServer -auto”

yazın.

4. İsmine “Exchange Management Shell” yazın.

5. Oluşturduğunuz kısayol üzerinde sağ tuşa basıp özelliklere girin ve Shortcut sekmesinde bulunan Start in kısmında yazan yazıyı silin.

6. Change Icon’ı seçip %SystemRoot%\\Installer\\ altında bulunan ve {} klasörlerinin içinde powershell.exe yi bulup açın ve EMS iconunu seçin.

7. Oluşturduğunuz bu kısayolu %systemdrive%\\ProgramData\\Microsoft\\Windows\\Start Menu\\Programs\\Microsoft Exchange Server 2010 altına kopyalayın.

Yayınlayan: Serkan Varoğlu

Yıldız Teknik Üniversitesi Elektrik Mühendisliğini bitirdim. Türkiye'de birçok farklı sektör ve firmada Sistem Yöneticiği yaptım. Bermudada 3 yıla yakın danışmanlık yaptıktan sonra şu anda İrlanda'da çalışma hayatıma devam ediyorum.